Seltsames Registryproblem

Dieses Thema im Forum "Software Probleme" wurde erstellt von Marcus, 03.09.2006.

  1. Marcus

    Marcus Guest

    Hallo!

    Mein Rechner: Fujitsu Siemens Scaleo 600, AMD Athlon XP 2200+, Mainboard: Gigabyte GA-7VAXFS, 1,5 GB Arbeitsspeicher

    WinXP, Build 5.1.2600, Service Pack 1

    Ich habe ein seltsames und unglaublich hartnäckiges Registry-Problem. Es fing damit an, dass ich Mitte August einen neuen Kartenleser installierte, diesen hier:

    http://www.kosatec.de/kosatec/content/ek/shop/detail.php?art=365051

    (Nicht bei der Firma Kosatec gekauft, um Missverständnisse zu vermeiden). Zuerst schien alles normal. Aber wenn auf den zu lesenden Speicherkarten Unterverzeichnisse angelegt waren, konnte man durch simple Verzeichniswechsel den Rechner zuverlässig zum Absturz bringen. Das war an sich schon überraschend, weil bis dahin mein Rechner sehr stabil gelaufen war. Noch überraschender war, dass die Fehlercodes beim BSOD auf einen schwerwiegenden Fehler hinwiesen: "Registry Error" mit einem Code, der immer mit 0x00000051 begann. Nichts schien zu helfen, deswegen löste ich das Problem mit dem Tool USBDLM,

    http://www.uwe-sieber.de/usbdlm.html

    mit dem man USB-Drives in leeren NTFS-Verzeichnisse mounten kann. Es gab ein kleineres Problem mit den Schreibrechten für die Entfernung von Verzeichnissen (das ging nur über die XP-Eingabeaufforderung), aber ansonsten lief die Arbeit mit dem Kartenleser ab da glatt. Ich hatte mich damit abgefunden, dass mein Rechner den Kartenleser nur in dieser Art halbwegs problemlos integrieren konnte - nun gut.

    Nach einer Abwesenheit von etwa einer Woche kehrte ich an den Rechner zurück und musste feststellen, dass jetzt sowohl mein internes DVD-RW- als auch mein DVD-ROM-Laufwerk, als auch mein interner Iomega-ZIP-Drive die gleichen Symptome zeigten wie vorher der Kartenleser. CDs, DVDs, und ZIP-Disks waren erkennbar und lesbar. Audio-CDs sowie Film-DVDs waren lesbar, das Brennen von CDs funktionierte ebenso. Aber das Herumnavigieren in Verzeichnissen und Unterverzeichnissen, die auf den CDs abgelegt waren, brachte den Rechner zuverlässig zum Absturz. Typischerweise aber erst ab einer gewissen Verzweigungstiefe: Hauptverzeichnisse und Unterverzeichnisse des ersten Grades sind meistens noch ok, ab Untervezeichnissen des zweiten Grades wird es haarig. Weder meine interne Festplatte, noch die beiden USB-Festplatten, die ich als Backup-Lösung benutze, haben diese Probleme. Ansonsten läuft der Rechner völlig problemlos.

    Hier einige Dinge (wenn auch nicht alle) die ich - ohne Erfolg - getan habe, um das Problem zu lösen:

    - Entfernung der betroffenen Laufwerke im Gerätemanager, anschließende Neuinstallation

    - Entfernung des oben erwähnten Kartenlesers und Ersetzung durch einen älteren SanDisk MemoryStick-Leser, mit dem ich vorher ohne jedes Problem gearbeitet hatte (und jetzt auch wieder)

    - Entfernung aller Laufwerke bis auf das absolute Minimum. Ich hatte geglaubt, dass möglicherweise mein Netzteil unter bestimmten Umständen überlastet sei, das war nicht der Fall.

    - Überprüfung der betroffenen Laufwerke und des primären und sekundären IDE-Kanals im Gerätemanager. Überprüfung des Gerätemanagers auf Hardwarekonflikte (es waren keine auffindbar).

    - Überprüfung der Ereignisanzeige in der Computerverwaltung. Bis auf ein triviales Problem mit dem Modul "userenv" unauffällig. Man kann diese Problem mit einem Fix von Microsoft lösen, das wird aber nur empfohlen, wenn der Rechner tatsächlich zu langsam herunterfährt, was bei mir nicht der Fall ist.

    - Veränderung der Laufwerksbuchstaben über die Datenträgerverwaltung. Dies verschlimmerte das Problem, schon ein Klicken auf die Laufwerksbuchstaben im Arbeitsplatz brachte danach den Rechner zum Absturz.

    - Wiederanschalten der "AutoPlay"-Funktion für die betroffenen Laufwerke. "AutoPlay" ist bei mir üblicherweise abgeschaltet. Nachdem ich es wieder einrichtete, brauchte der Rechner ein wenig länger, um abzustürzen, das war der einzige Unterschied.

    - Systemwiederherstellung anhand verschiedener Prüfpunkte aus der Zeit vor der Installation des problematischen Kartenlesers (Mitte August), im letzten Fall stammte der Prüfpunkt von Anfang Juli. Das war eine der seltsamsten Angelegenheiten: Das Problem *schien* dadurch bereinigt, aber wenn man ein wenig hartnäckiger in den Verzeichnissen herumkletterte, stellte es sich sofort wieder ein.

    - Systemwiederherstellung aus dem abgesicherten Modus. Ergebnis wie oben. Der Fehler mit den BSOD-Abstürzen per Verzeichnisnavigation tritt auch im abgesicherten Modus auf (gleiche Fehlermeldung).

    - Öffnung des Systemkonfigurationsprogramms, Durchführung des Diagnosesystemstarts. Der Fehler tritt auch hier auf.

    - Starten des Rechners über die Revovery-CD und Überprüfung des Systemdatenträgers mit chkdsk /p /r. Chkdsk meldete mir die Auffindung und Lösung eines Problems auf dem Datenträger, die Abstürze bei der Benutzung der betroffenen Laufwerke blieben.

    - Installation der Debugging Tools von Microsoft und Untersuchung des Memory Dumps von den BSOD-Ereignissen. Leider konnten die Tools das Problem nicht eingrenzen ("Analysis Inconclusive"), der erhoffte Hinweis auf einen defekten Treiber o.ä. ergab sich nicht. Es kann durchaus sein, dass ich die Debugging Tools nicht richtig angewendet habe, aber für eine genauere Arbeit auf dieser Ebene habe ich einfach nicht die Zeit.

    - Da sich in einem Fall iTunes mit einer Fehlermeldung meldete, deinstallierte ich iTunes. Das hatte keine Auswirkung auf den Fehler.

    Mein Workaround ist fast derselbe wie bei dem problematischen Kartenleser. Ich lasse den Laufwerken zwar ihre Laufwerksbuchstaben, damit Medienplayer eingelegte CDs und DVDs erkennen und abspielen können, aber ich mounte sie zusätzlich in leeren NTFS-Verzeichnissen (über die Datenträgerverwaltung). Als Verzeichnisse sind sie absolut unproblematisch einsehbar, es kommt nicht zu Abstürzen.

    Einige Dinge, die noch von Belang sein könnten:

    - Eines der betroffenen Laufwerke wird zwar vom BIOS immer richtig erkannt, aber im Gerätemanager wurde es nur als CD-Laufwerk beschrieben. Wenn ich es aus dem Gerätemanager entfernte und nach einem Systemstart neu installieren ließ, wurde es unter seinem vollen Namen angezeigt (Plextor 708a).

    - Alle Hinweise zu 0x00000051-Fehlern, die per Google finden konnte, befassten sich mit Problemen, die beim Start von Windows auftraten, das ist bei mir nicht der Fall. Aber natürlich ist meine Hauptsorge, dass es bald bei mir der Fall sein könnte. Alles, was ich bei Microsoft zu dem Fehler finden konnte, bezog sich Windows 2000, oder auf Probleme mit dem Systemkonfigurationsprogramm, die durch die Installation von Service Pack 2 behoben werden können. Aber das Systemkonfigurationsprogramm lässt sich bei mir problemlos öffnen, der Rechner gehorcht vorbildlich, wenn ich ihn damit manipuliere.

    Wer weiß Rat?

    Viele Grüße,

    Marcus
     
  2. AdMan

    schau mal hier: Windows-Wartungs-Tool. Viele Probleme lassen sich damit einfach beheben. Oftmals ist der PC dann auch schneller!
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren.
Thema:

Seltsames Registryproblem

Die Seite wird geladen...

Seltsames Registryproblem - Ähnliche Themen

  1. Seltsame Zeichen

    Seltsame Zeichen: Hallo, als ich eben meinen USB Stick auslesen wollte, der Schock: Keine Bilder, und auch keine Bezeichnungen mehr, stattdessen sehr eigenartige...
  2. seltsame Datei

    seltsame Datei: Moin! Ich habe auf meiner Festplatte zwei Odner gefunden, die da gestern noch nicht waren und irgendwie einen seltsamen Inhalt haben....
  3. Seltsame und kuriose Problem-Meldungen erscheinen ("Remote-Application Terminated", etc)

    Seltsame und kuriose Problem-Meldungen erscheinen ("Remote-Application Terminated", etc): Hallo, hier mein Problem. 1.) Mein Laptop läuft ständig auf 100% Auslastung und nur selten geht es einmal kurz etwas runter auf etwa 80% 2.)...
  4. Seltsame Probleme- ich weiss nicht mehr weiter.

    Seltsame Probleme- ich weiss nicht mehr weiter.: Hallo. Eins vorweg... ich hab wenig ahnung von computedingen und muss von meinem handy aus alles schreiben. Wenn ihr mir irgendwas sagt, was...
  5. Samsung SSD 840 PRO Werte seltsam? [mit Bild]

    Samsung SSD 840 PRO Werte seltsam? [mit Bild]: Servus, hab jetzt mal meine SSD mit einem Benchmark-Tool getestet und es sind folgende Werte bei rausgekommen, die mich etwas verunsichert haben:...