Probleme HTML: background-color für "body" funktioniert nicht

Diskutiere Probleme HTML: background-color für "body" funktioniert nicht im Webmaster Hilfe / Programmierer Forum Forum im Bereich Computerprobleme; Hallo, ich schreibe gerade eine Website mit css, und ich möchte den Hintergrund der Seite ändern, jedoch geht das nicht. Könnt Ihr mal den Code...

  1. #1 MaxKraft, 05.10.2017
    MaxKraft

    MaxKraft Benutzer

    Dabei seit:
    01.05.2015
    Beiträge:
    39
    Zustimmungen:
    2
    Hallo,

    ich schreibe gerade eine Website mit css, und ich möchte den Hintergrund der Seite ändern, jedoch geht das nicht. Könnt Ihr mal den Code ansehen und sagen, was da nicht stimmt?

    CSS-Datei:

    <?xml version="1.0" encoding="UTF-8"?>
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
    "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml" xml:lang="de">

    body {
    background-color: lightgrey;
    }
    ...

    <?xml version="1.0" encoding="UTF-8"?>
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
    "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml" xml:lang="de">
    <head>
    ...
    </head>
    <body>
    ...

    </body>
    </html>

    Danke!
     
  2. Anzeige

    schau dir mal diesen Ratgeber an. Dort findet man viele Hilfestellungen.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren.
  3. #2 JudgeLG, 06.10.2017
    JudgeLG

    JudgeLG Erfahrener Benutzer

    Dabei seit:
    04.01.2013
    Beiträge:
    1.324
    Zustimmungen:
    42
    Ort:
    Niedersachsen
    <html>
    <head>
    <style type="text/css">
    body {
    .....
    }
    </style>
    </head>
    <body>
    ...
    </body>
    </html>
     
  4. #3 MaxKraft, 06.10.2017
    MaxKraft

    MaxKraft Benutzer

    Dabei seit:
    01.05.2015
    Beiträge:
    39
    Zustimmungen:
    2
    Das funktioniert nicht.
    Der Anfang des HTML-Dokuments sieht jetzt wie folgt aus:

    <?xml version="1.0" encoding="UTF-8"?>
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
    "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml" xml:lang="de">
    <head>
    <link href="style.css" rel="stylesheet" type="text/css">
    body {
    background-color: lightgrey;
    }
    <title>
    ABC
    </title>
    <meta http-equiv="content-type" content="text/html; charset=utf-8">
    </style>

    </head>
    <body>
    ...

    Ich habe
    body {
    background-color: lightgrey;
    }
    jetzt in <head> eingefügt und </style> hinzugefügt, aber keine Änderung.
    Vielleicht soltle ich noch erwähnen, dass ich css für andere Elemente des Dokuments verwende, und die ohne Probleme wie gewünscht dargestellt werden.
     
  5. #4 MaxKraft, 06.10.2017
    MaxKraft

    MaxKraft Benutzer

    Dabei seit:
    01.05.2015
    Beiträge:
    39
    Zustimmungen:
    2
    Okay, ich habe das jetzt hinbekommen. Der HTML-Code sieht so aus:

    <?xml version="1.0" encoding="UTF-8"?>
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
    "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml" xml:lang="de">
    <head>
    <link href="style.css" rel="stylesheet" type="text/css">
    <title>
    ABC
    </title>
    <meta http-equiv="content-type" content="text/html; charset=utf-8">
    </style>

    </head>
    <body style="background-color:lightgrey;">
    </body>

    Ich bin aber ein bisschen verwirrt: Warum ging das nicht mit CSS?
     
  6. #5 xandros, 07.10.2017
    xandros

    xandros IT Consultant, Cisco Registered Partner
    Moderator

    Dabei seit:
    05.07.2007
    Beiträge:
    26.508
    Zustimmungen:
    159
    Ort:
    Umkreis Duisburg, neben Mannheim, hinter Hamburg
    Das ist auch jetzt noch immer CSS, nur eben in den HTML-Quelltext eingebettet und nicht in einer separaten Datei.

    Nebenbei:
    <link href="style.css" rel="stylesheet" type="text/css">
    erwartet, dass die CSS-Datei "style.css" heisst und im gleichen Verzeichnis wie die HTML-Seite liegt.
    -> Richtiges Verzeichnis? Dateiname korrekt und dabei auch Klein-/Grossschreibung berücksichtigt?
    Style.css ist nicht identisch mit style.css
     
Thema:

Probleme HTML: background-color für "body" funktioniert nicht

Die Seite wird geladen...

Probleme HTML: background-color für "body" funktioniert nicht - Ähnliche Themen

  1. Windows 10 Probleme beim Start und bei der Benutzung

    Windows 10 Probleme beim Start und bei der Benutzung: Hallo, Als ich heute mittag meinen PC hochfahren wollte, kam eine Meldung, dass ein Problem aufgetreten sei und dieses erst behoben werden muss....
  2. Windows Patch Probleme

    Windows Patch Probleme: Hallo, jemand mitbekommen, ob es bei den April 2018 Patches Probleme gibt? Mir fällt da eins ins Auge. KB4093118
  3. SSH funktioniert nicht (java.io.IOException: End of IO Stream Read)

    SSH funktioniert nicht (java.io.IOException: End of IO Stream Read): Hallo ihr Lieben, Ich habe Probleme mich mit meinem Raspberry Pi über Ssh zu verbinden. Das Betriebsystem des Raspberry (Raspbian OS, das auf...
  4. Touchscreen funktioniert nicht mehr

    Touchscreen funktioniert nicht mehr: Moin, nach einer Neuinstallation von Windows 10 funktioniert der Touchscreen des Lenovo Yoga 300 IBY nicht mehr. Sämtliche Treiber habe ich...
  5. Amazone Prime Probleme

    Amazone Prime Probleme: Hallo leute, mal ne Frage. Hat jemand Erfahrung mit Amazone Prime App Streaming auf Smart TV. Habe ne VDSL 50000 Leitung und egal ob mit LAN...
  1. Diese Seite verwendet Cookies um Inhalte zu personalisieren. Außerdem werden auch Cookies von Diensten Dritter gesetzt. Mit dem weiteren Aufenthalt akzeptierst du diesen Einsatz von Cookies.
    Information ausblenden