Probleme HTML: background-color für "body" funktioniert nicht

Diskutiere Probleme HTML: background-color für "body" funktioniert nicht im Webmaster Hilfe / Programmierer Forum Forum im Bereich Computerprobleme; Hallo, ich schreibe gerade eine Website mit css, und ich möchte den Hintergrund der Seite ändern, jedoch geht das nicht. Könnt Ihr mal den Code...

  1. #1 MaxKraft, 05.10.2017
    MaxKraft

    MaxKraft Benutzer

    Dabei seit:
    01.05.2015
    Beiträge:
    39
    Zustimmungen:
    2
    Hallo,

    ich schreibe gerade eine Website mit css, und ich möchte den Hintergrund der Seite ändern, jedoch geht das nicht. Könnt Ihr mal den Code ansehen und sagen, was da nicht stimmt?

    CSS-Datei:

    <?xml version="1.0" encoding="UTF-8"?>
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
    "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml" xml:lang="de">

    body {
    background-color: lightgrey;
    }
    ...

    <?xml version="1.0" encoding="UTF-8"?>
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
    "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml" xml:lang="de">
    <head>
    ...
    </head>
    <body>
    ...

    </body>
    </html>

    Danke!
     
  2. Anzeige

  3. #2 JudgeLG, 06.10.2017
    JudgeLG

    JudgeLG Erfahrener Benutzer

    Dabei seit:
    04.01.2013
    Beiträge:
    1.431
    Zustimmungen:
    66
    Ort:
    Niedersachsen
    <html>
    <head>
    <style type="text/css">
    body {
    .....
    }
    </style>
    </head>
    <body>
    ...
    </body>
    </html>
     
  4. #3 MaxKraft, 06.10.2017
    MaxKraft

    MaxKraft Benutzer

    Dabei seit:
    01.05.2015
    Beiträge:
    39
    Zustimmungen:
    2
    Das funktioniert nicht.
    Der Anfang des HTML-Dokuments sieht jetzt wie folgt aus:

    <?xml version="1.0" encoding="UTF-8"?>
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
    "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml" xml:lang="de">
    <head>
    <link href="style.css" rel="stylesheet" type="text/css">
    body {
    background-color: lightgrey;
    }
    <title>
    ABC
    </title>
    <meta http-equiv="content-type" content="text/html; charset=utf-8">
    </style>

    </head>
    <body>
    ...

    Ich habe
    body {
    background-color: lightgrey;
    }
    jetzt in <head> eingefügt und </style> hinzugefügt, aber keine Änderung.
    Vielleicht soltle ich noch erwähnen, dass ich css für andere Elemente des Dokuments verwende, und die ohne Probleme wie gewünscht dargestellt werden.
     
  5. #4 MaxKraft, 06.10.2017
    MaxKraft

    MaxKraft Benutzer

    Dabei seit:
    01.05.2015
    Beiträge:
    39
    Zustimmungen:
    2
    Okay, ich habe das jetzt hinbekommen. Der HTML-Code sieht so aus:

    <?xml version="1.0" encoding="UTF-8"?>
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
    "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml" xml:lang="de">
    <head>
    <link href="style.css" rel="stylesheet" type="text/css">
    <title>
    ABC
    </title>
    <meta http-equiv="content-type" content="text/html; charset=utf-8">
    </style>

    </head>
    <body style="background-color:lightgrey;">
    </body>

    Ich bin aber ein bisschen verwirrt: Warum ging das nicht mit CSS?
     
  6. #5 xandros, 07.10.2017
    xandros

    xandros IT Consultant, Cisco Registered Partner
    Moderator

    Dabei seit:
    05.07.2007
    Beiträge:
    26.651
    Zustimmungen:
    198
    Ort:
    Umkreis Duisburg, neben Mannheim, hinter Hamburg
    Das ist auch jetzt noch immer CSS, nur eben in den HTML-Quelltext eingebettet und nicht in einer separaten Datei.

    Nebenbei:
    <link href="style.css" rel="stylesheet" type="text/css">
    erwartet, dass die CSS-Datei "style.css" heisst und im gleichen Verzeichnis wie die HTML-Seite liegt.
    -> Richtiges Verzeichnis? Dateiname korrekt und dabei auch Klein-/Grossschreibung berücksichtigt?
    Style.css ist nicht identisch mit style.css
     
Thema: Probleme HTML: background-color für "body" funktioniert nicht
Besucher kamen mit folgenden Suchen
  1. css body background-color funktioniert nicht

Die Seite wird geladen...

Probleme HTML: background-color für "body" funktioniert nicht - Ähnliche Themen

  1. GnuPG mit Serpent funktioniert nicht, obwohl libgcrypt installiert ist

    GnuPG mit Serpent funktioniert nicht, obwohl libgcrypt installiert ist: Hi, ich bin noch (GnuPG) Knoppix-Einsteiger und möchte folgende symmetrische Verschlüsselungen nur im Terminal durchführen, ohne grafische...
  2. UDF Dateien machen Probleme

    UDF Dateien machen Probleme: Es handelt sich um gebraucht gekaufte Spielfilme. Die Softwäre heißt Power DVD. Auf W7 mit dem Windows media player laufen die Filme. Auf dem...
  3. DSL Probleme - Virenscanner

    DSL Probleme - Virenscanner: Hallo, ich habe da mal eine Frage, und wäre dankbar wenn mir jemand drauf antworten könnte. Seit Tagen konnte mein Laptop keine...
  4. Microsaoft Maus- und Tastaturcenter funktioniert nicht mehr

    Microsaoft Maus- und Tastaturcenter funktioniert nicht mehr: Ich habe jetzt win 10 64GB installiert. Aber jetzt geht das Microsoft Maus- und Tastaturcenter nicht mehr. Ich habe eine Intellimouse 6000 mit...
  5. Zertifikat Probleme

    Zertifikat Probleme: Hallo, habe ein neues Zertifikat erstellt und auch abgeschlossen. Das Zertifikat ist auch gültig. Nur habe ich das Problem, das die...
  1. Diese Seite verwendet Cookies um Inhalte zu personalisieren. Außerdem werden auch Cookies von Diensten Dritter gesetzt. Mit dem weiteren Aufenthalt akzeptierst du diesen Einsatz von Cookies.
    Information ausblenden