Excel-Formel

Diskutiere Excel-Formel im Alles für den Einsteiger Forum im Bereich Computerprobleme; Hallo! Ich habe eine Excel-Formel, die nicht laufen will. Code ist:...

  1. #1 Leseflo, 20.01.2010
    Zuletzt bearbeitet: 20.01.2010
    Leseflo

    Leseflo Benutzer

    Dabei seit:
    23.08.2007
    Beiträge:
    90
    Zustimmungen:
    0
    Hallo!
    Ich habe eine Excel-Formel, die nicht laufen will.
    Code ist:
    Code:
    =WENN(B11=4;60;=WENN(B11=8;120;=WENN(B11=13;180;=WENN(B11=18;240;=WENN(B11=24;300;=WENN(B11=30;360;=WENN(B11=37;420;=WENN(B11=44;480;=WENN(B11=51;540;=WENN(B11=60;600;=WENN(B11=68;660;=WENN(B11=78;720;=WENN(B11=88;780;=WENN(B11=99;840;=WENN(B11=110;900;=WENN(B11=122;960;=WENN(B11=136;1020;=WENN(B11=150;1080;=WENN(B11=165;1140;=WENN(B11=180;1200;=WENN(B11=197;1260;=WENN(B11=216;1320;=WENN(B11=235;1380;=WENN(B11=255;1440;=WENN(B11=277;1500;=WENN(B11=300;1560;=WENN(B11=325;1620;=WENN(B11=351;1680;=WENN(B11=378;1740;=WENN(B11=408;1800;=WENN(B11=439;1860;=WENN(B11=472;1920;=WENN(B11=507;1980;=WENN(B11=544;2040;=WENN(B11=584;2100;=WENN(B11=626;2160;=WENN(B11=670;2220;=WENN(B11=717;2280;=WENN(B11=766;2340;=WENN(B11=818;2400;"Fehler!"))))))))))))))))))))))))))))))))))))))))
    Pseudocode
    Code:
    Wenn B11 4 ist, dann der Wert 60, sonst Wenn B11 8 ist, dann der Wert 120, sonst Wenn ...
    Kann mir einer helfen und sagen, wo der Fehler in dieser Riesengroßen Formel liegt?

    Danke euch allen im Vorraus.

    Leseflo.
     
  2. Anzeige

    schau mal hier: Windows-Wartungs-Tool. Viele Probleme lassen sich damit einfach beheben. Oftmals ist der PC dann auch schneller!
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren.
  3. #2 Computergroup, 20.01.2010
    Computergroup

    Computergroup Benutzer

    Dabei seit:
    28.11.2009
    Beiträge:
    45
    Zustimmungen:
    0
    probiers mal damit:

    =WENN(B11=4;60;WENN(B11=8;120;WENN(B11=13;180;WENN(B11=18;240;WENN(B11=24;300;"Fehler!")))))

    usw.

    MfG
     
  4. 123Uwe

    123Uwe Erfahrener Benutzer

    Dabei seit:
    08.02.2008
    Beiträge:
    282
    Zustimmungen:
    0
    Der Fehler liegt bei den = Zeichen. Vor der Prüfung "sonst" darf dieses nicht verwendet werden (es beginnt ja dort keine neue Gleichrechnung, sondern die Fortsetzung der Formel. Du schreibst schließlich vor 60, 120 usw. auch kein = Zeichen.
     
  5. #4 Leseflo, 21.01.2010
    Zuletzt bearbeitet: 21.01.2010
    Leseflo

    Leseflo Benutzer

    Dabei seit:
    23.08.2007
    Beiträge:
    90
    Zustimmungen:
    0
    Funktioniert leider immer noch nicht.

     
  6. Sigi

    Sigi
    Moderator

    Dabei seit:
    14.08.2008
    Beiträge:
    8.341
    Zustimmungen:
    2
    Ort:
    Schillsdorf
    Schreib mal Klartext und an Hand von Beispielen was Du genau berechnet haben willst.
    Vielleicht kann Dir dann jemand die richtige Formel einstellen.
     
  7. Que

    Que Neuer Benutzer

    Dabei seit:
    12.02.2008
    Beiträge:
    2.307
    Zustimmungen:
    0
    Ort:
    Innsbruck
    ne das geht nicht, bei den älteren versionen können maximal 7 oder 8 wenn-funktionen verschachtelt werden!!!
     
  8. 123Uwe

    123Uwe Erfahrener Benutzer

    Dabei seit:
    08.02.2008
    Beiträge:
    282
    Zustimmungen:
    0
    Stimmt, maximal 8
    Que hat wie meistens recht
     
  9. Que

    Que Neuer Benutzer

    Dabei seit:
    12.02.2008
    Beiträge:
    2.307
    Zustimmungen:
    0
    Ort:
    Innsbruck
    ???

    du meinst IMMER!!!

    :D :D :D
     
  10. #9 Leseflo, 21.01.2010
    Leseflo

    Leseflo Benutzer

    Dabei seit:
    23.08.2007
    Beiträge:
    90
    Zustimmungen:
    0
    Also, ich will halt, wenn B11 = 4 dann bekommt ein anderes Feld den wert 60 usw.

    Wenn das auch anders geht, wär schön.

    Muss ja auch nicht umbedingt über =WENN-Befehle gemacht werden, wenn jemand noch ne andere Lösung kennt.
     
  11. heinzl

    heinzl .

    Dabei seit:
    29.01.2008
    Beiträge:
    8.276
    Zustimmungen:
    9
    Sinnvollerweise verwendet man dazu SVERWEIS. Dazu brauchst du eine Hilfstabelle mit den gesuchten Werten und den Rückgabewerten. Einfach mal in der Excelhilfe nachschlagen.
     
  12. 123Uwe

    123Uwe Erfahrener Benutzer

    Dabei seit:
    08.02.2008
    Beiträge:
    282
    Zustimmungen:
    0
    :cool::cool::cool:
     
  13. Anzeige

    Es ist generell erstmal empfehlenswert alle ggf. veralteten oder fehlerhaften Treiber zu scannen und auf neue zu aktualisieren. Hier kannst du einen Treiber-Scanner downloaden. Das erspart oftmals viel Ärger und hilft gegen diverse Probleme.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren.
  14. Que

    Que Neuer Benutzer

    Dabei seit:
    12.02.2008
    Beiträge:
    2.307
    Zustimmungen:
    0
    Ort:
    Innsbruck
    ich wüßte wie es geht ist aber etwas aufwendiger, bin nicht so erfahren mit excel-funktionen:

    du gehst in die TABELLE 2 und gibst beginnend mit A1 nummern fortlaufend ein, also
    im feld A1 gibst du ein 1, im Feld A2 gibst du ein 2, im feld A3 gibst du ein 3... das kopierst du dir bis zum feld A818 in welches dann 818 stehen muss...

    im Feld B2 bis Feld B818 kopierst du dir das Wort FEHLER!...

    dann überschreibst du das Wort FEHLER! neben jeder Zahl bei welcher nun nicht das Wort FEHLER! sondern deine gewünschte Zahl erscheinen soll, dh im Feld B4 überschreibst du FEHLER! mit der Zahl 80, im Feld B8 schreibst du 120 usw...

    dann gehst du in die TABELLE 1 und fügst folgende funktion in das feld ein in welchem entweder FEHLER! oder eben deine zahl stehen soll:

    =SVERWEIS(B11;Tabelle2!A1:B818;2)

    er sucht somit die zahl welche im Feld B11 steht in der Tabelle 2 vom Feld A1 bis B818 und wenn er die zahl gefunden hat, schreibt er die zahl bzw das wort welches neben dieser zahl in der spalte B steht...
     
  15. #13 Leseflo, 13.02.2010
    Leseflo

    Leseflo Benutzer

    Dabei seit:
    23.08.2007
    Beiträge:
    90
    Zustimmungen:
    0
    Danke!
    Ich probier das morgen gleich mal aus.
     
Thema: Excel-Formel
Besucher kamen mit folgenden Suchen
  1. excel grundformeln

    ,
  2. excel grundformel

    ,
  3. exel formel von seite zu seite

    ,
  4. grundformel exel,
  5. excelformel 30/360,
  6. grundformel in Excel,
  7. grundformeln excel,
  8. excel formel :60
Die Seite wird geladen...

Excel-Formel - Ähnliche Themen

  1. Excel-Tabelle teilen mit Script?!

    Excel-Tabelle teilen mit Script?!: Moin Leute, ich hoffe ich bin hier richtig und jemand hat eine Idee für mich: Das Problem ist, ich habe eine Excel-Liste, worin sich ca. 60...
  2. Excel und Word öffnet sich beim Hochfahren immer automatisch

    Excel und Word öffnet sich beim Hochfahren immer automatisch: Hallo, ich bekomme noch eine Krise. Irgendwann habe ich mal eingestellt, dass sich Excel und Word beim Hochfahren des Computers selbständig öffnen...
  3. Wahrscheinlichkeitsberechnung bei Monopoly mithilfe von Excel

    Wahrscheinlichkeitsberechnung bei Monopoly mithilfe von Excel: Hallo, Ich brauche bezüglich meiner Seminararbeit eine Simulation, die mir sagt, mit welcher Wahrscheinlichkeit ich auf bestimmten Feldern lande...
  4. Excel Frage

    Excel Frage: Hallo , eine frage zum Microsoft Excel Ich Arbeite neuerdings mit einer Preisliste via Microsoft Excel im Betrieb. Da ich dort Preise auf die...
  5. Excel: 2 Spalten mit einander vergleichen und Fremdwert

    Excel: 2 Spalten mit einander vergleichen und Fremdwert: Ich würde gerne Spalte H und Spalte K mit einander vergleichen. Wenn 2 gleiche Werte gefunden werden, soll der Wert aus Spalte J (immer Links von...