Brauche Hilfe mit Eclipse Versionen und OSGi

Dieses Thema im Forum "Software Probleme" wurde erstellt von Copperfield, 27.02.2010.

  1. #1 Copperfield, 27.02.2010
    Copperfield

    Copperfield Neuer Benutzer

    Dabei seit:
    27.02.2010
    Beiträge:
    5
    Zustimmungen:
    0
    Hallo,

    ich möchte mit Eclipse auf der OSGi Plattform programmieren. Nun will ich gerade die erforderlichen Programme installieren und stoße auch viele verschiedene Versionen. Leider kenn ich mich weder besonders mit Eclipse noch Java aus und die Bücher, die ich habe benutzen veraltete Versionen, die es so nicht mehr gibt.
    Ich hatte vor einem Jahr mal Eclipse Ganymed installiert. Ist es besser wenn ich jetzt Eclipse Galileo installiere?
    Wo ist der Unterschied zwischen eclipse-java-galileo-SR2 oder eclipse-SDK-3.5.2?
    Welche Eclipse IDE soll ich installieren, bzw. um was handelt es sich genau?
    Was ist das JDK? Ich denke fast, dass ich es schon habe, kann es aber nirgends auf meinem Computer finden.

    Weiß jemand, was ich genau von OSGi bzw. Equinox noch installieren muss?

    Ich freue mich auf Antworten!
     
  2. AdMan

    schau mal hier: Windows-Wartungs-Tool. Viele Probleme lassen sich damit einfach beheben. Oftmals ist der PC dann auch schneller!
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren.
  3. #2 xandros, 27.02.2010
    xandros

    xandros IT Consultant, Cisco Registered Partner
    Moderator

    Dabei seit:
    05.07.2007
    Beiträge:
    25.891
    Zustimmungen:
    91
    Ort:
    Umkreis Duisburg, neben Mannheim, hinter Hamburg
    Die ist mir gar nicht bekannt. (Hatte vor Galileo noch die Europa im Einsatz)
    Java Development Kit (Das Paket für Entwickler, im Gegensatz zur JRE = Java Runtime Environement)
    Ja. Du arbeitest bestimmt auch nicht mehr mit einem völlig veralteten Betriebssystem....
    ..ist das aktuelle Paket von Eclipse inkl. der JDK, CVS Cient, XML Editor und Mylyn.
    Das Standardpaket von Eclipse, in dem nur die JDK enthalten ist.
    Kommt darauf an, was du zusätzlich noch haben willst. Wenn die reine IDE inkl. JDK ausreicht, würde ich das Standardpaket verwenden.

    Für Equinox:
    Eclipse downloads - mirror selection
    Sollte jedoch auch innerhalb der IDE nachinstallierbar sein.
     
  4. #3 Insonamia, 27.02.2010
    Insonamia

    Insonamia Erfahrener Benutzer

    Dabei seit:
    28.12.2009
    Beiträge:
    121
    Zustimmungen:
    0
    Ich benutze als Hobbyprogrammiere Eclipse Ganymed. Was ziemlich flüssig läuft.

    Was du natürlich brauchts ist Java, wie xandors erklärt hat.
    Wenn Eclipse einmal läuft kannst du dich im die IDEs kümmern.
     
  5. #4 xandros, 28.02.2010
    Zuletzt bearbeitet: 28.02.2010
    xandros

    xandros IT Consultant, Cisco Registered Partner
    Moderator

    Dabei seit:
    05.07.2007
    Beiträge:
    25.891
    Zustimmungen:
    91
    Ort:
    Umkreis Duisburg, neben Mannheim, hinter Hamburg
    Eclipse ist schon die IDE. Alles was zusätzlich installiert werden kann (also die AddOns) sind nur Spracherweiterungen, Designtools etc.

    ...ah! Ganymede ist die Projekt-Version 3.4.x von 2008.
    Gehört zeitlich also hinter Callisto (2006) und Europa (2007) bzw. vor Galileo (2009).
    Soweit ich das eben auf der Webseite der Eclipse Foundation sehen konnte, wird Ganymede immer noch gepflegt und etliche Projektkomponenten weiterentwickelt.
    Wäre also durchaus denkbar, dass man diese Version - je nach Verwendungsbereich - durchaus noch weiterhin benutzen muss, sofern für Galileo die passenden AddOns noch nicht verfügbar sind.
     
  6. #5 Copperfield, 28.02.2010
    Copperfield

    Copperfield Neuer Benutzer

    Dabei seit:
    27.02.2010
    Beiträge:
    5
    Zustimmungen:
    0
    Danke für die Antworten.

    Mittlerweile hab ich Galileo installiert und bin zufrieden.

    Nur eine Frage habe ich noch.

    Ich hab gesehen, dass ich drei jre Versionen habe: jre6, jre1.6.0_07 und jre1.6.0_03.

    Kann ich die letzten beiden löschen? jre6 müsste doch reichen?
     
  7. #6 xandros, 28.02.2010
    xandros

    xandros IT Consultant, Cisco Registered Partner
    Moderator

    Dabei seit:
    05.07.2007
    Beiträge:
    25.891
    Zustimmungen:
    91
    Ort:
    Umkreis Duisburg, neben Mannheim, hinter Hamburg
    jre 1.6.x ist eine aktualisierte Version von jre6.
    Du solltest mal kontrollieren, ob du das letzte Update jre6u18 installiert hast.
     
  8. AdMan

    Es ist generell erstmal empfehlenswert alle ggf. veralteten oder fehlerhaften Treiber zu scannen und auf neue zu aktualisieren. Hier kannst du einen Treiber-Scanner downloaden. Das erspart oftmals viel Ärger und hilft gegen diverse Probleme.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren.
Thema: Brauche Hilfe mit Eclipse Versionen und OSGi
Besucher kamen mit folgenden Suchen
  1. welche eclipse version habe ich

    ,
  2. welche eclipse version

    ,
  3. welche eclipse version installieren

    ,
  4. unterschiede eclipse versionen,
  5. welches eclipse brauche ich,
  6. eclipse version unterschied,
  7. unterschied eclipse java versionen,
  8. eclipse versionen,
  9. welsche version von eclipse habe ich,
  10. welcher eclipse-version habe ich,
  11. welche eclipse version hab ich,
  12. welche eclipse version brauch ihc,
  13. eclipse version unterschiede
Die Seite wird geladen...

Brauche Hilfe mit Eclipse Versionen und OSGi - Ähnliche Themen

  1. Hilfe! Überfordert!

    Hilfe! Überfordert!: Hallo zusammen, Ich habe ein Problem, bei dem ich noch nicht mal sicher weiß, ob es sich um ein Software- oder Hardware-Problem handelt (also...
  2. Neuling braucht Hilfe bei Grafikkarte, Bluescreen/Absturz und Internet Baustellen

    Neuling braucht Hilfe bei Grafikkarte, Bluescreen/Absturz und Internet Baustellen: Hallo. Ich bin relativer Neuling in der Materie Hardware/Software... Vor wenigen Jahren ging meine Festplatte hinüber - warum auch immer... Ich...
  3. HILFE!Ati Catalyst Control Center gelöscht

    HILFE!Ati Catalyst Control Center gelöscht: Guten Morgen! Gestern habe ich einen riesigen Mist mit meinem Laptop angestellt... Ich wollte mehr Platz schaffen, weilschon andauernd die Meldung...
  4. Hilfe bei der Zusammenstellung

    Hilfe bei der Zusammenstellung: Hallo, Ich baue mir gerade einen Rechner zum zocken zusammen:...
  5. Hilfe ich werd Wahnsinnig mit TP Link VR900v

    Hilfe ich werd Wahnsinnig mit TP Link VR900v: Guten Morgen zusammen, habe mir, nach dem meine fritzboxen abgekackt sind einen tp link vr900v gekauft. Mein internet anbieter ist Vodafone. Mit...