Booten mit RS232-Device

Dieses Thema im Forum "Hardware Probleme" wurde erstellt von member2001, 29.11.2005.

  1. #1 member2001, 29.11.2005
    member2001

    member2001 Guest

    Hallo,

    an meinem Rechner (WinXP, SP2, Firmennetzwerk) haengt am seriellen Port COM1 ein Datenerfassungssystem, das auf den Pin 2 des Rechners sendet.
    Die Datenerfassung und der Transfer ueber die RS232-Schnittstelle funktionieren sehr gut... Nur beim Einschalten hab ich Probleme. Wenn ich naemlich den Rechner MIT EINGESCHALTETER, also sendender Datenerfassungshardware, hochfahre, spinnt ploetzlich die Maus rum, huepft von Eck zu Eck usw.
    Weiss jemand, an was das liegt? Ich betone noch mal, wenn ich die Datenerfassung erst nach dem Hochfahren starte, gibt es keine Probleme.
    Vielen Dank schon mal!
    Marcel
     
  2. AdMan

    schau mal hier: Windows-Wartungs-Tool. Viele Probleme lassen sich damit einfach beheben. Oftmals ist der PC dann auch schneller!
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren.
  3. #2 K@rsten, 29.11.2005
    K@rsten

    K@rsten Erfahrener Benutzer

    Dabei seit:
    16.11.2005
    Beiträge:
    5.351
    Zustimmungen:
    0
    Ort:
    Am Berg Songshan. Ort Dengfeng in der Provinz Hena
    Ist dies ein Laptop oder eine normale Workstation?
     
  4. #3 member2001, 30.11.2005
    member2001

    member2001 Guest

    Hallo,

    ne, ist ein normaler PC in einem Firmennetzwerk. Weiss nicht, ob er den Begriff Workstation verdient, jedenfalls ist es ein grosser grauer Kasten unter meinem Schreibtisch :)

    Koennte es was damit zu tun haben?
     
  5. #4 K@rsten, 30.11.2005
    K@rsten

    K@rsten Erfahrener Benutzer

    Dabei seit:
    16.11.2005
    Beiträge:
    5.351
    Zustimmungen:
    0
    Ort:
    Am Berg Songshan. Ort Dengfeng in der Provinz Hena
    Bleibt das so mit der Maus, oder stellt sich das Problem dann mit der Zeit ab?
     
  6. #5 member2001, 30.11.2005
    member2001

    member2001 Guest

    Aehm,

    das kann ich nicht so genau sagen. Immer, wenn das Problem aufgetaucht ist, hab ich naemlich nicht lange gewartet, bis es von allein verschwunden ist. Sondern hab halt den Rechner herunter gefahren, das Device herausgezogen, den Rechner gestartet und das Device wieder eingesteckt... siehe da, hat funktioniert.

    Also innerhalb von 5 Minuten nach dem Booten verschwindet das Problem sicherlich nicht, laenger hab ich es leider nicht beobachtet. Soll ich mal machen? Oder kannst Du damit auch schon was anfangen?
     
  7. #6 K@rsten, 30.11.2005
    K@rsten

    K@rsten Erfahrener Benutzer

    Dabei seit:
    16.11.2005
    Beiträge:
    5.351
    Zustimmungen:
    0
    Ort:
    Am Berg Songshan. Ort Dengfeng in der Provinz Hena
    Ist die Maus PS2?

    Ich würde es dann mal mit er USB Maus versuchen - oder aber auch umgekehrt!
     
  8. #7 member2001, 30.11.2005
    member2001

    member2001 Guest

    Ja, die Maus ist PS2.

    Ich koennte das mal Ausprobieren, ja, einen PS2 auf USB - Adapter zu verwenden. Falls es dann funktioniert, umso besser.

    Das waere ja dann eine relativ einfache Loesung des Problems. Ich haette eigentlich erwartet, dass dieses Problem ein XP-internes ist und es dazu irgendwo einen Patch herunterzuladen gibt.

    Leider ist das mit der Maus aber nicht das Einzige Problem. Ich hab zwei Geraete an zwei COM-Ports haengen. Das eine bekommt ueber COM1 Daten vom Rechner gesendet. Das andere schickt ueber COM2 Daten an den Rechner. Nun stellte sich, als auch das Problem mit dem huepfenden Mauszeiger auftrat, die komische Situation ein, dass das Geraet an COM1 ploetzlich einen String anzeigte, der von dem Geraet an COM2 geschickt wurde! Und da hab ich eben gedacht, dass der interne Bus irgendwie nicht damit zurecht kommt, dass das eine Geraet sowohl sendet als auch an das andere etwas geschickt werden soll.

    Koennte eine zusaetzliche serielle Schnittstellenkarte Abhilfe schaffen? Um die beiden Ports besser zu entkoppeln oder so?

    Fragen ueber Fragen... vielen Dank fuer Deine Hilfe!
     
  9. #8 K@rsten, 30.11.2005
    K@rsten

    K@rsten Erfahrener Benutzer

    Dabei seit:
    16.11.2005
    Beiträge:
    5.351
    Zustimmungen:
    0
    Ort:
    Am Berg Songshan. Ort Dengfeng in der Provinz Hena
    Ein 2. Schnittstelle wäre empfehlenswert!

    Die Merkmale eines Buses sind nunmal, dass dieser in einem Zyklus alle Teilnehmer abfragt und dies in einer best. Reihenfolge. Wenn dieser dabei durcheinander kommt, gibt es die tollsten Ausfälle!


    Habt Ihr bei euch keine IT Abteilung?
    Setze diese mal darauf an > Verbesserungsvorschlag!
     
  10. AdMan

    Es ist generell erstmal empfehlenswert alle ggf. veralteten oder fehlerhaften Treiber zu scannen und auf neue zu aktualisieren. Hier kannst du einen Treiber-Scanner downloaden. Das erspart oftmals viel Ärger und hilft gegen diverse Probleme.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren.
  11. #9 member2001, 30.11.2005
    member2001

    member2001 Guest

    Also nehmen wir mal an, ich wuerde mir eine Karte besorgen, die zwei serielle Pors zur Verfuegung stellt. Dann wuerde ich das eine Geraet an den COM-Port des Rechners klemmen und das andere an eine Schnittstelle der Karte.

    Das Problem wird dadurch aber doch nur verlagert, oder? Weil intern kann ich mir vorstellen, dass die Signale trotzdem zusammengefuehrt und auf einen Bus gelegt werden, oder? Egal von welcher Schnittstelle sie kommen.

    Also welchen Vorteil haette eine Karte dann genau?
     
  12. #10 K@rsten, 30.11.2005
    K@rsten

    K@rsten Erfahrener Benutzer

    Dabei seit:
    16.11.2005
    Beiträge:
    5.351
    Zustimmungen:
    0
    Ort:
    Am Berg Songshan. Ort Dengfeng in der Provinz Hena
    Ob sich daraus ein Vorteil ergibt ist in der Tat fraglich.

    Aber die Probleme scheinen aus dieser Koniguration zu kommen.
    Also könnte man es mal so probieren!
     
Thema: Booten mit RS232-Device
Besucher kamen mit folgenden Suchen
  1. pc über rs 232 starten

    ,
  2. win7 boot problem rs232 ausgabe

    ,
  3. Computer über RS232 einschalten

    ,
  4. ausgabe über serielle schnittstelle beim booten bei windows 7,
  5. mauszeiger spinnt wenn rs232,
  6. rs232 maus spinnt,
  7. pc per rs232 hochfahren,
  8. booten rs232 kommt durcheinander,
  9. rs232 beim booten,
  10. pc booten über rs232,
  11. rs232 pc booten,
  12. rechner per rs232 booten
Die Seite wird geladen...

Booten mit RS232-Device - Ähnliche Themen

  1. Eset Smart Security und Multi-Device-Security Unterschied

    Eset Smart Security und Multi-Device-Security Unterschied: Mein Virenschutz von Eset läuft demnächst ab. Jetzt habe ich mich bei den Produkten umgesehn. Was ist denn nun der Unterschied zwischen Eset Smart...
  2. Boot Probleme Abit AB9 Quad GT

    Boot Probleme Abit AB9 Quad GT: Hi, folgendes Problem: ich habe o.g. Mainboard mit einem Core2Duo, 4 GB RAM etc. Alles Standard Komponenten. BS: Win10 Der Rechner hat auf einmal...
  3. Von CD/DVD Booten funktioniert nicht!

    Von CD/DVD Booten funktioniert nicht!: Hallo erstmals! Ich besitze seit ca 1 Woche den Medion Desktop PC und habe jetzt ein grosses Problem und zwar bezüglich des CD/DVD booten. Wenn...
  4. Win 7 Boot Fehler

    Win 7 Boot Fehler: Hallo Leute, Habe versucht das Betriebssystem Win 7 x64 auf meinem alten Rechner neu aufzusetzen. Der Rechner lief ursprünglich mit dieser...
  5. Brauche dringend Hilfe. "No Bootable Device"

    Brauche dringend Hilfe. "No Bootable Device": Guten Tag liebe Community, ich habe folgendes Problem: Ich wollte für einen Freund seinen Laptop neu Formatieren etc. weil dieser von Viren...